S k a t e L o g     F o r u m
Inline Skating and Quad Roller Skating
Forum Hosts: Jessica Wright | Kathie Fry

FOLLOW US: Our Blog | Facebook | Twitter | Email    


Home - Forum Index - Africa Skating - Asia Skating - Europe Skating - Oceania Skating - Pan America Skating - Roller_Rinks - Friend the SkateLog Forum in Facebook - SkateLog Forum on Facebook

Forum Administrators: Jessica Wright and Kathie Fry | Email Us
Access code for buying and selling subforums: "skates"
How To Get a User Account and Posting Privileges in the SkateLog Forum
Use Google to Search the SkateLog Forum

Go Back   SkateLog Forum > Special Interest Skating Forums (sorted by number of posts) > Roller Derby Forum
FAQ Calendar Search Today's Posts Mark Forums Read

Roller Derby Forum Discussions about banked-track and flat-track roller derby events, teams, skaters, and training methods.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old April 5th, 2016, 02:08 PM   #1
Juice_
Junior Member
 
Join Date: Mar 2016
Posts: 5
Default SG Avenger Skate/Plate Tuning

Hello All,

I've read many similar threads here on the forum regarding SG Avengers and I'm having trouble make sense of all of it. I'm gonna spit out some basics here to hopefully keep it short.

I'm a derby skater, primarily a jammer. I'm 5'1 and about 125 lbs. For two years, I skated on basic Sure Grip Rebels with a Probe plate. I changed those up eventually too better bearings and purple cushions and loosened the trucks. And was using 88a Heartless wheels (loved these suckers). We skate on a mix of floors, Mondays its super sticky sport court and on Thursday it is polished concrete.

I upgraded to a new sure grip boot (which I love) and a sport mounted SG Avenger plate with purple cushions, trucks tighten all the way down and same wheels. I could immediately tell these plates were different but not in a bad way, just different. My issue is - I cannot for the life of me plow stop anymore. I cannot get chatter. I just glid and slide and go and never stop.

Is this a technique issue? I have a feeling it is due to the fact that the axle is now located in a different place along my foot.

Any advice?
Juice_ is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.